PDA

View Full Version : Missing PS Fluid



biketsai
03-05-2008, 11:25 PM
where did it go?
I recently had a leak, fixed that and topped the car off with the power steering fluid. A little later I go and look at it, and it lookks empty but I don't hear the power steering creeking

Eurotuned_A4
03-05-2008, 11:30 PM
how long ago did you top it off. My power steering fluid has gotten low 2 times since i have owned the car.

aytheory
03-06-2008, 02:05 AM
mmm you should check the ps cooler - it is under the bumper - if it leaks you should start seeing residue build up - because the way the tubes are connected to the ps cooler are by those one time use clamp and they go bad - so time to look under the car.

I've been lazy to flush my system out - =(

biketsai
03-06-2008, 06:24 AM
see that's the thing, I just replaced those clamps

audisnapr
03-06-2008, 07:13 AM
maybe all the lines were empty. after you topped off the res, all the fluid just filled up all the lines. if its not leaking on the ground somewhere, chances are you just need to put more in.

onemoremile
03-06-2008, 11:03 AM
^^^ That is my guess too. The system probably wasn't completely full. Top it off and roll the steering wheel slowly from lock to lock a few times.

isleepsober
03-06-2008, 01:40 PM
thats what happened to me.... then i found out my steering rack was bad... 800 to fix that.

cross your fingers.

biketsai
03-06-2008, 02:34 PM
Well I guess what those guys said above, its true.
Level is fine now.

audisnapr
03-06-2008, 02:36 PM
stop making noises?

biketsai
03-06-2008, 02:40 PM
yes sir, thanks for your help