PDA

View Full Version : GIAC FXK04/"Hammer"



destrolock
02-21-2008, 05:08 PM
Hello everyone,

Recently I purchased an A4 1.8 avant and I was wondering if there was any way to tell if I actually have the GIAC FXK04/"Hammer" programming. I have Vag-com, if that helps.

Thanks in advance!

audiFUEGO
02-21-2008, 05:28 PM
If you step on it, and it actually feels like is kinda going... a little...


then you have it.

GetBoosted84
02-21-2008, 05:34 PM
If you step on it, and it actually feels like is kinda going... a little...


then you have it.

lol, yeah so true.

Also you could hook your vag-com cable up and use giac's flashloader program for windows to see if it sees your chip, my hammer file came with race, stock, and pump programs.

OR you could just look at the boost gauge and see if it goes above 11 psi.

destrolock
02-21-2008, 05:41 PM
Great info guys, thanks. Boost gauge max at ~14-15 pounds. Was told it has a k04-15.

audiFUEGO
02-21-2008, 05:51 PM
Could be one of two things:

1. You have a few boost leaks.

2. You have the regular GIAC file for k04. (Not hammer)

destrolock
02-21-2008, 06:01 PM
This is true, I might have a few boost leaks, as I notice a whoooshing sound when I hammer on the throttle. I thought it might be intake noise also as I have a Carbonio gen 1.

I am planning on doing the tennis ball test this weekend, hopefully that will sort it out for me.

What is the max psi a k04 with the "hammer" can or should produce?

audiFUEGO
02-21-2008, 06:12 PM
youll be spiking 25 psi in gear 4

destrolock
02-21-2008, 06:16 PM
DAAMNNN..well if that is true then I have a major boost leak somewhere. Thanks for your help AF!

Nebone
02-21-2008, 06:34 PM
Maybe it has a K04 on a K03 chip.

grip_racer
02-21-2008, 06:44 PM
^^nebone is probably right

destrolock
02-21-2008, 07:13 PM
hrmm well this is all good food for thought. I will check the vag, do the tennis ball test and report back.

Solaris
02-21-2008, 08:02 PM
Why not just pull the ECU and see if there's a label on the chip?

destrolock
02-21-2008, 08:11 PM
I will do so. Is there usually a label on these chips?

Solaris
02-21-2008, 08:18 PM
I guess it depends on who installed it. AWE labels them.

Poopie
02-21-2008, 10:50 PM
do you have an exhaust? FMIC? what maf? these are much easier ways to find out what you most likely have.

audiFUEGO
02-22-2008, 04:58 AM
^^^ true

destrolock
02-22-2008, 08:02 AM
Yes the car has a Greddy FMIC along with (what I was told) a TT maf. 3" down pipe on stock exhaust.

Poopie
02-22-2008, 08:09 AM
with a tt maf you should definantly have the hammer file.

destrolock
02-22-2008, 08:13 AM
Ok thanks Poopie. What would be the quickest way to identify if I actually have a TT maf?

I looked and did'nt see a part number on it.

Poopie
02-22-2008, 08:14 AM
measure the diameter

destrolock
02-22-2008, 09:46 AM
Ok i'll measure the Diameter and report back this evening.

gotaudi
02-23-2008, 10:46 PM
should be 3" inner diameter

ianlionzion
02-24-2008, 11:55 AM
If it's this car, then it should be.

http://www.audizine.com/forum/showthread.php?t=183383&highlight=avant+fxk04+dyno

destrolock
02-24-2008, 12:24 PM
Yes that is my new obsession. I was only curious how to tell if I had the chip in general.

destrolock
02-27-2008, 01:09 PM
Update for you guys.

I hooked up the vag cable and used GIAC flashloader utility, it indeed came up with the 3 options:

Stock
Pump
Race

Pump was highlighted in green. I also found a tear in the recirc piping from the bov back to the turbo. I replaced that piece of hose but am still only boosting to 15~16 pounds max. I have yet to do the tennis ball test, which I imagine I will find more leaks.

I did notice something last night after getting home from work. After the car was turned off, I heard a faint hissing sound coming from the passenger side of the engine bay. I couldn't pinpoint it, but my question is, is the system still charged even after the engine has been shut off? I didn't think it was, but I just wanted to ask. If so, anybody else ever experienced this hissing just after shut off?

Anyway just wanted to give an update and thanks for your help again.

audiFUEGO
02-27-2008, 01:12 PM
the hissing is your AC... very normal.

destrolock
02-27-2008, 01:13 PM
oh.. would that be the compressor? I didn't have the AC on though. Does that matter?

audiFUEGO
02-27-2008, 01:15 PM
yes im pretty sure its the compressor... and no i dont think it should be doing it if you didnt have the AC on.

destrolock
02-27-2008, 01:16 PM
hrmmm now that is interesting.. I did have the heater on though.

audiFUEGO
02-27-2008, 01:23 PM
you can have the heater on with the AC compressor working.

destrolock
02-27-2008, 01:32 PM
Ok thanks.. that's probably what it was then.

ModifiedA4
02-27-2008, 03:09 PM
Hello everyone,

Recently I purchased an A4 1.8 avant and I was wondering if there was any way to tell if I actually have the GIAC FXK04/"Hammer" programming. I have Vag-com, if that helps.

Thanks in advance!

judging by a previous hammer log posted, i'd say log block 115 and if the requested boost is 2500mbar, then its a hammer.

destrolock
03-01-2008, 04:54 PM
So would that be 2500 mbar at WOT in 3rd gear? At Idle I am at 1010 mbar. At 5k rpm I spiked 2040 mbar in 3rd. I am probably dealing with a major boost leak still somewhere. But I don't know. I can throw up the logs if anyone wants to see them.

*EDIT*

I'm also sitting at -13% partial fuel trim. From reading Audi_FUEGO's posts in another thread I guess that answers my question about a boost leak. It must be fairly large.

Still wondering about the Hammer though.