PDA

View Full Version : Testpipe CEL solution?



MikeWasHere05
10-02-2007, 07:07 PM
I'm getting a testpipe/borla setup soon and I'm thinking about how to fix the CEL problem thats going to pop up.

What if I just don't put the secondary O2 sensor in? Put a rubber cap on it or something to keep it somewhat clean, zip tie to to the firewall or something and cover the hole in the test pipe.

Is it that easy?

audiFUEGO
10-02-2007, 07:29 PM
no you will need it in there.

buy some spark plug foulers from dicsount autoparts... drill right thru them... stack a couple on top of eachother and screw it into ur testpipe... then screw the 02 sensor into your stack.

this lifts the 02 sensor out of the stream of exhaust.

seank
10-02-2007, 07:53 PM
yep def go with the spark plug anti-fouler setup it is super easy and has worked on my car for almost a year now with no cel. search for how to do it, it has been covered numerous times.

SurferForever
10-02-2007, 11:22 PM
So does the O2 sensor just send an electrical current to the ecu? If so, shouldnt we be able to splice a resistor into the line somewhere to fix it real easily?

seank
10-03-2007, 05:26 AM
you can use a resistor yes, but why mess with wiring when you can just screw something into the testpipe.

pipe7284
10-03-2007, 06:14 AM
how far out does the o2 sensor has to be? meaning how many spark plug foulers do we have to screw before the o2 sensor?

RobbyB413
10-03-2007, 06:15 AM
I'm getting a testpipe/borla setup soon and I'm thinking about how to fix the CEL problem thats going to pop up.

Did you call GIAC to see if they have an update to your file specifically for TPs that would keep that from happening?

Yaktizzle417
10-03-2007, 06:28 AM
Lol at you spending $730 on exhaust...

but yeah just do the fouler mod, OR have GIAC reflash your ECU to not throw a code.

superman_006
10-03-2007, 06:34 AM
I have a 98 1.8t and one of the short ones (part # 42009 from advance auto parts), I drilled the center out to 1/2" works great

Here is the write up I followed, its great and has lost of pics

http://forums.audiworld.com/a4/msgs/2511177.phtml


Here is a pic of mine installed
http://i130.photobucket.com/albums/p276/superman_006/ebay07119.jpg

audiFUEGO
10-03-2007, 06:52 AM
Lol at you spending $730 on exhaust...

but yeah just do the fouler mod, OR have GIAC reflash your ECU to not throw a code.

LOL @ you.

Borla is the shit.

And btw, GIAC is the only company that does not cancel CEL.

MikeWasHere05
10-03-2007, 08:09 AM
Lol at you spending $730 on exhaust...

but yeah just do the fouler mod, OR have GIAC reflash your ECU to not throw a code.

Lol @ $600 shipped stainless steel 2.5" turboback.


I'll just do the defoulers, I figured I'd just ask about not putting it in at all.

ct1.8t4me
10-03-2007, 08:12 AM
The diode inline in the wiring is a lot easier in my opinion - unless you are scared of electronics and can only turn a wrench [;)]

There is a write up on AudiWorld and I have a post on here discussing it. I have had one on my setup with a 3" ATP Testpipe for thousands of miles now with no ill effects and no CEL.

If you are installing the TP now, then the antifouler mod is fine to do at the same time, but if you have already installed it, the diode is an easy fix and you don't have to get dirty doing it.

Just another option to weigh.

Militant-Grunt
10-03-2007, 09:28 AM
I have a 98 1.8t and one of the short ones (part # 42009 from advance auto parts), I drilled the center out to 1/2" works great

Here is the write up I followed, its great and has lost of pics

http://forums.audiworld.com/a4/msgs/2511177.phtml


Here is a pic of mine installed
http://i130.photobucket.com/albums/p276/superman_006/ebay07119.jpg

42009s are too short for our 02's. I had to take one and cut it in half, and weld it ontop of another. 42002's which have a bit more room work better.

pinky
10-03-2007, 09:38 AM
i did my TP a week and a half ago and no cel yet (finger crossed)

i've heard great thing about the wayne angle block (search it on vwvortex)

JumboBlack1.8
10-03-2007, 09:40 AM
I used 2 42009s on my ER testpipe....works well....Just drilled through the top one and screwed it into the lower one.....Passed MA state inspection with it last week

onemoremile
10-03-2007, 09:42 AM
Why not just screw the 02 sensors into a HFC. Simple, legal, and 99% of the power of a test pipe. A lot easier to install too.

TinaTbolt
10-09-2007, 01:09 PM
What TP did you get? im getting EuroCode...

d_maniac
10-09-2007, 03:58 PM
what is the exact CEL that you will get with a TP?

audiFUEGO
10-09-2007, 04:15 PM
what is the exact CEL that you will get with a TP?

"inefficient catalyst"