PDA

View Full Version : Strange CEL!



libtech75
08-16-2007, 10:55 AM
Last Saturday I got around to refilling my windshield washer fluid reservoir. Prior to this the car was running totally fine, absolutely no check engine lights or anything.

I went to the store and purcahsed the washer fluid. I filled the reservoir full with fluid, to the point it came up to the cap. I spilled some while filling but nothing major.

As soon as I got in the car, a CEL had lit up! I wondered whether it might be a loose cap, so I made sure the cap was on tight. I then thought maybe somehow I overfilled the reservoir? So I sprayed fluid until the wiper fluid level was well below the cap.

The light is still on. Anyone know of anything CEL that could have been triggered in connection with the windshield wiper fluid reservoir? This is the strangest thing. No way a CEL went on exactly the same time I filled the wiper fluid by coincidence for something else!

Nebone
08-16-2007, 11:29 AM
Can't just guess what it could be. Check what the code is and go from there. The reservoir has nothing to do with a CEL. Only sensor in there is a low level sensor which triggers the Warning screen, but not CEL.

onemoremile
08-16-2007, 11:47 AM
My only guess is that you spilled fluid on something but nothing should be affected by washer fluid. Anything that fluid could get to would get wet in the rain anyway. If you don't have a vag-com then stop by a pep-boys and get the code scanned and cleared. It may be just coincidence.

libtech75
08-22-2007, 08:47 AM
I found out I have the flex pipe leak. Any chance the CEL is a result of that leak? It's gotten bigger and louder.

Rather than paying $300 for flex pipe replacement and repair, I'm just swapping out stock exhaust for new Borla Exhaust this weekend.

AudiRacerS4
08-22-2007, 08:50 AM
nope an exhaust leak after the o2 sensors would not trigger a CEL

sjthomas
08-22-2007, 08:50 AM
that's a much more likely cause of the CEL than the washer fluid. enjoy the borla!

libtech75
08-22-2007, 09:19 AM
Damn I wonder what it is. I hope it's nothing big. That dreaded CEL light on an Audi makes my heart beat fast. It's all maintenance, wear and tear type work I've been getting done on the car recently but everything all at once. Close to 2K in one month. I need a bit of a break... ugh

Euro-Tuner
08-22-2007, 09:19 AM
I'll bet your misfiring, it never fails!

...everytime some does something to their cars that should effect nothing, it misfires, just my guess