PDA

View Full Version : Forge 007 DV (?)



dukez
07-27-2007, 02:24 PM
Does anyone elses 007 when twisted completely down, won't allow any movement at all?

I went to check/service my 007 valve just now, after reading this manual (http://www.forgemotorsport.com/media/valve_service(1).pdf)
specifically to do the "leak test" and then i noticed, the piston doesn't even move at all when i try to push it in! [eek]

This ****** was never working/recirculation for all this time, no wonder i was bogging. I reviewed the design of the gizmo, and it seems completely faulty to me. When the cover is screwed down tight, (how its suppose to?) it sits flush right on top of the piston thing in the center, there no way that things moving. So i untwisted it until the piston was able to be pushed in, and its only like after two turns of the cap (loose as ever). I tried wrapping some Teflon tape around the threads, and it secured it a bit, but the cap can still be turned left or right.

But at least I can get the piston deal to move and recirculate air like its suppose to. I did a test run after i put it back in if feels so much better than before (or ever). I think I'm going to order a 710N valve again, and throw this one away after the 710 comes in.

Thoughts?

Oyeah, after i got the piston to move, i did that leak test with my finger over the nipple, and it closed every time (failed). Never held its positon. I mean, it closed, and when i let my finger off, you can hear the extra little bit of vacuum go out, but the thing didn't hold at all.

onemoremile
07-27-2007, 02:36 PM
You should be able to put the cap on tight and push the piston in with a dowel or the back of a Sharpie. It isn't easy to push in since you are compressing the spring.

dukez
07-27-2007, 04:51 PM
Well thats not happening on mine. I have the cap twisted about two or three times, plenty of thread left for it to go down more. Any more though, it'll stop the piston from moving.