PDA

View Full Version : Why cant I get this ? (Bilstein and Ecs sleeve install)



Rosati
06-04-2007, 12:45 PM
Yeah I know, I should have got coilovers the first time around
http://www.audizine.com/gallery/data/500/419206-04-07_1515-med.jpg

But im doing the rears now and just cant get this to work. The Spring seat just doesnt budge. I called up ecs and they told me to go at it w/ a mallet. I sure as hell went at it to no avail, with a mallet and hammer-- Thing wont budge. I read something about a c clamp on the shock from the website install... am i missing something? Why cant i get this off? Also, they sleeve doesnt go past the bilstein label halfway down the shaft. Im guessing it will recede once i put it into the car and the weight will do the rest......


Thanks in advance.

http://www.audizine.com/gallery/data/500/419206-04-07_1516-thumb.jpg0
http://www.audizine.com/gallery/data/500/419206-04-07_1514-thumb.jpg

97audia4
06-04-2007, 08:40 PM
you might have to place a screw driver in the side of the stock spring perch, or try turning it from side to side, i know they come off, mine did when i replace my sport spring eith h&r race springs, how long have you had those on? try using some wd-40 or liquid wrench

UN-PIMP-Z-A4
06-05-2007, 06:17 AM
Wd40 or some other type of lube...
Then use the rubber mallet.

I would not use a screw driver in fear of puncturing the strut itself.

97audia4
06-05-2007, 08:19 AM
try heating it up a little bit as well

ActiveMonkey
06-05-2007, 08:36 AM
Heat Gun + Liquid Wrench x Mallet = my best guess