PDA

View Full Version : Need advice, oil consumption!



BranCKY3
05-06-2007, 10:36 PM
So... last night I'm driving on the highway and my car starts beeping. The minimum oil light came on, I thought the sensor was being retarded so I cycled the ignition, but it came back on. Pulled over at a gas station and checked the oil, there's none showing on the stick. So I go inside and buy a quart, fill it back up and all is good. This happened to me ~2-3 months ago also...

Anyway, I searched on here and found out some people have had problems with their crankcase breather systems and oil consumption. Besides the pancake valve on the turbo inlet, what else should I try to clean to unclog the system if that were to be my problem? Should I take the valve cover off and clean everything in there? I somehow doubt it's a mechanical problem in the engine, as it runs very strong as I proved at the track recently [:D] [:p] Engine runs smooth, no leaks, etc.

Hopefully someone will chime in that had the same problem and fixed it by unclogging the breather system...

superman_006
05-07-2007, 08:09 AM
You could check the PCV vavle, its under the intake manifold, you could hook the hose connecting the PCV valve to the intake manifold and try to suck/ blow to see if its working like a check valve, your turbo would be were I would look next, If you take the tubo output hose off and there is oil runs out then you found you problem. The possibly valve seals or maybe a combination of them. And most importantly, you should check you oil more than once ever 2-3 months

PS what turbo are you running to acheive 12.6 ?

solowb5
05-07-2007, 08:17 AM
if u have improper drainage of the oil it will back up in the turbo and burn it up. also to high of oil pressure without sufficient drainage will do the same.

BranCKY3
05-07-2007, 08:20 PM
You could check the PCV vavle, its under the intake manifold, you could hook the hose connecting the PCV valve to the intake manifold and try to suck/ blow to see if its working like a check valve, your turbo would be were I would look next, If you take the tubo output hose off and there is oil runs out then you found you problem. The possibly valve seals or maybe a combination of them. And most importantly, you should check you oil more than once ever 2-3 months

PS what turbo are you running to acheive 12.6 ?

I'll check the PCV valve, thanks. I DO check my oil more than every 2-3 months, I just said that it happened 2-3 months ago but I didn't think anything of it. I did an oil change like a month ago before I went to the dragstrip.

Running a 2871r elim from ATP to get that 12.6