PDA

View Full Version : Wont hold boost!



tombomb84
04-15-2007, 04:13 PM
Lately I have been noticing that when i mash the gas to the floor, the boost will spike to around 20, but then it will drop to about 10 once i get to about 6000 rpms. I have a ko4 with an mbc set to 20 lbs. Could this be a boost leak, or is it just the ko4 is so small it has a hard time holding that much boost?

maxspeed
04-15-2007, 04:45 PM
what programming are you running? also what DV? have you checked for boost leaks?

tombomb84
04-15-2007, 05:09 PM
I running a giac ko4 chip, with a baileys dv. I checked for boost leaks about a month ago and only found one, which was my turbo outlet pipe. The only place i could find that part was the dealership.

tombomb84
04-16-2007, 08:17 AM
Seriously does anyone know what could be happening with my car?

mike-2ptzero
04-16-2007, 08:39 AM
Seriously does anyone know what could be happening with my car?

are you running just a MBC or the MBC with the N75 valve?

Euro
04-16-2007, 10:02 AM
Im KO3 and have a simalar problem. I know that the KO3/KO4's will lose some PSI at higher engine speeds because they are a small turbo.

They have the quick spool and build boost fast, but they loose high end beacuse of that.

I can spike around 17-18 psi and then drop down to 11-12 psi around 6000 rpm. Im just chipped and KO3. So I would thnk you could hold more than me...

a4cefed
04-16-2007, 11:06 AM
any fault codes ? like mike said n75 or mbc? could be a bad n75 valve or could be a bad wastegate. any rattle on decel?