PDA

View Full Version : ATP Turbo Inlet Problem



Oricle
04-11-2007, 11:28 PM
This thing is a pain in the ass. I ended up getting it close to completed, but had to drive it down to the body shop for the body kit(about .5 miles away). The airbox wouldn't close because of how the inlet can't get a good grab on the MAF sensor, the PCV valve wont go on in place, and the black ciruclar piece can't reconnect to the hose it was originally connected onto because they didn't supply me with a long enough hose.

Drove it there with a massive boost leak as you can tell. Did anyone else have major fitment problems with this? Is the 2 piece Inlet pipe with the silver 90* bend even for the B5 A4's? I should get it back next week and have this problem sorted out with ATP I'm hoping while it's in there.

Poopie
04-11-2007, 11:43 PM
[headbang] [headbang] [headbang] [headbang] [headbang]

see other post.

mike-2ptzero
04-12-2007, 09:24 AM
Just do yourself a favor, box it up, send it back and buy yourself something better. You might have to spend a little more money. But your back, hands and head will thank you later, plus you will end up with a better flow of air into the turbo. ATP did a real hack job on the B5 3" TIP kit vs the B6.

Oricle
04-12-2007, 10:41 AM
Just do yourself a favor, box it up, send it back and buy yourself something better. You might have to spend a little more money. But your back, hands and head will thank you later, plus you will end up with a better flow of air into the turbo. ATP did a real hack job on the B5 3" TIP kit vs the B6.

I e-mailed ATP and told them I wanted to return it. They told me they'd try to get the bugs, etc worked out of it. I'll give it a shot. Wish I had the car here right now and it wasn't at the body shop.