PDA

View Full Version : Shaking car + CEL



MikeWasHere05
04-05-2007, 09:24 PM
So today I was on E and got about 5 gallons of 92 octane at the local Getty. I've been getting gas there since I bought the car and haven't had any problems.

I drive a few miles, pick up my girlfriend, then we go to rent a movie. Cars running fine. We get out of the movie place and start up the car and its like shaking. I don't like it, but no idiot lights go on so I figure I'll just drive to her house, then drive home and deal with it in the AM.

About 200 feet down the road and the CEL starts blinking, pull into Pizza Hut. I decide I'll just drive it home (no other option really) and take my dad's truck. I start driving it and now the CEL is solid, but about a mile later (after I was at a red light) it stops shaking. Its driving fine, but the CEL is still on.

I don't have a vagcom (will be getting one after I get back from spring break), but I'm taking it to my indy mechanic tomorrow to see whats up. The oil hasn't been changed in about 4,000 miles (was gonna do it tomorrow, as well as put my new wheels on). Does anyone have any idea what it could be? I know its hard without any codes, so if nobody has a clue this is a good vent I guess. [headbang]

Whatever, worse could happen.

k0mpresd
04-05-2007, 09:29 PM
sounds like an ignition problem but its weird it stopped doing it after driving for a little while

cel blinking is def misfires and a constant cel will be from multiple cylinder misfires (along w/ the other thousand that could cause it to stay on)

possibly could be icm

tunerb5
04-05-2007, 09:43 PM
im gonna place my money on the icm.....i've replaced 2 already so believe me I know..

burner799
04-05-2007, 09:48 PM
yea...i'd put money on it being the ICM too. same thing hapend with mine. replaced with a beru one.