PDA

View Full Version : Can bad/not-synthetic oil cause this..



bronz
04-03-2007, 04:46 PM
camshaft position sensor problems? i keep gettin CEL for camshaft position sensor, i jsut recently bought my 01 1.8tqms from dealership and i think they use shitty oil might even be not synthetic... im changing my oil this weeknd... any input would help thanks

Ewok_Fetus
04-03-2007, 04:48 PM
No, it shouldn't.... If you bought it from an Audi dealership then they SHOULD have put in synthetic... If they didn't, never go back to that dealer again!

bronz
04-03-2007, 05:47 PM
wasnt audi dealer... it looks like shitty non synthetic oil... should i replace my camshaft position sensor or if i keep getting cels afteri change my oil?

edit: i screwed up in first post and said throttle position sensor instead of camshaft position sensor...

Ewok_Fetus
04-03-2007, 06:30 PM
Ah!! Camshaft posistion sensor huh?! Yes the oil COULD cause it to go bad I guess but that is WELL over time... I HIGHLY doubt that one oil change with non-synthetic would cause this... It is a common problem on the 2001 1.8t's... It isn't urgent that you get it fixed now, just when you have the time/money and all... You can find them on eBay for about $175 new from this one guy. I forget his name... But the DIY is probably difficulty No. 3-4 on a scale to 10... If you can't find it on ebay, just troll the forums looking for one... I think there is one for sale right now for cheap in the for sale forums...

Ewok_Fetus
04-03-2007, 06:31 PM
Nevermind... Dunno why I was thinking Cam Chain Tensioner... Disregard everything I said... The Cam posistion sensor is not affected by oil at all... So no... It wasn't the oil change... Get a new sensor though... $35 usually I think...

bronz
04-03-2007, 06:53 PM
hmm 80$ at autozone for bosch one ... ill look around, for oil change should i just get regular filter or should i get s4 one or any other suggestions?

Ewok_Fetus
04-03-2007, 07:05 PM
Get OEM filters. You can get one at a VW dealer, they are usually cheaper there... Just tell them it is for a 2001 Passat 1.8 though... I tried to tell my VW dealer here that it was going to go on an Audi A4 and he wouldn't sell me one... What a dick... So I said, fine, I will get one for my 2001 Passat and he gave me one...

europshhrc279
04-03-2007, 08:37 PM
thats the reason my check engine light is on aswell =(..been on since i bought the car..scanned it at autozone and read 1 code ..camshaft positioning sensor...i think it was 90 from autozone...havnt bothered to change it out...maybe soon i will...car runs fine and all so w.e

tamadrumr88
04-04-2007, 04:43 AM
I tried to tell my VW dealer here that it was going to go on an Audi A4 and he wouldn't sell me one... What a dick... So I said, fine, I will get one for my 2001 Passat and he gave me one...

amen brother, thank god for b5 passats [up]