PDA

View Full Version : Bad throtle response at low RPM



sighpost
03-19-2007, 05:41 PM
A little back ground.....
My car has not run very much for the last 7 mos. It has not run at all for the last 3 months. When I started it two days ago it idled rough and would lag when I hit the gas. Then it would come back down through low idle and stall.

I replaced the fuel, the fuel filter and spark plugs. I checked my vacum lines. Now the throtle responds fine from idle but the engine cant sustain rpm between 1000 and 3000. Above 3000 the throttle responds just fine. But when I let the gas out it almost stalls when it comes back through ilde.

I already swaped in another DV and that didn't help. I have a steady CEL. Please help.

Oricle
03-19-2007, 05:45 PM
A little back ground.....
My car has not run very much for the last 7 mos. It has not run at all for the last 3 months. When I started it two days ago it idled rough and would lag when I hit the gas. Then it would come back down through low idle and stall.

I replaced the fuel, the fuel filter and spark plugs. I checked my vacum lines. Now the throtle responds fine from idle but the engine cant sustain rpm between 1000 and 3000. Above 3000 the throttle responds just fine. But when I let the gas out it almost stalls when it comes back through ilde.

I already swaped in another DV and that didn't help. I have a steady CEL. Please help.


What code is the CEL?

sighpost
03-19-2007, 05:56 PM
Not owning a VAG COM has caught up to me, I just ordered one and I will post the code as soon as I can.

CaSp3r9
03-19-2007, 07:06 PM
Oil change?

CaSp3r9
03-19-2007, 07:14 PM
Also, run some sea foam through your motor, your oil is probably sludge and I'd say it's a safe bet that there's a bunch of built up crud inside your block.

sighpost
03-20-2007, 10:32 AM
Can bad oil cause the low RPM problems?

sighpost
03-22-2007, 01:51 PM
Here is what VAG-COM returned. Any help would be appreciated.

Address 01: Engine
Part No: 8D0 907 557 P
Component: 1.8L R4/5VT MOTR HS D04
Coding: 06201
Shop #: WSC 06335

3 Faults Found:
18010 - Power Supply Terminal 30: Voltage too Low
P1602 - 35-10 - - - Intermittent
17967 - Throttle Body (J338): Fault in basic settings
P1559 - 35-10 - - - Intermittent
17953 - Throttle Valve Controller: Malfunction
P1545 - 35-00 - -
Readiness: 0010 0101

Oricle
03-22-2007, 02:06 PM
Here is what VAG-COM returned. Any help would be appreciated.

Address 01: Engine
Part No: 8D0 907 557 P
Component: 1.8L R4/5VT MOTR HS D04
Coding: 06201
Shop #: WSC 06335

3 Faults Found:
18010 - Power Supply Terminal 30: Voltage too Low
P1602 - 35-10 - - - Intermittent
17967 - Throttle Body (J338): Fault in basic settings
P1559 - 35-10 - - - Intermittent
17953 - Throttle Valve Controller: Malfunction
P1545 - 35-00 - -
Readiness: 0010 0101


Just going out on a limb, but maybe a bad TPS reading? What is your TPS voltage at idle? What is it when you drive with your foot inbetween the 1000-3000 RPM range?

ct1.8t4me
03-23-2007, 08:05 AM
Before you do anything, do a Throttle Body Adaptation: http://www.ross-tech.com/vag-com/cars/throttlebody.html

This may solve your problems.

xpl0sive
03-23-2007, 09:08 AM
also, rough idle may be caused by either bad plugs, coil packs or the ICM... here's how to test the icm
http://www.robsaudiworld.com/ignition.htm

sighpost
03-27-2007, 05:31 PM
I have replaced, the plugs, and replaced the fuel filter. I cleared the codes and tired to do a TBA but the TBA failed. I am down to just one code now.

17953 - Throttle Valve Controller: Malfunction
P1545 - 35-00 - -

Is it time for a new throttle body?

audiluver
03-27-2007, 06:31 PM
it could be that your throttle body is all gummed up. the reason your tba doesn't work could be because it's stuck and that is also why it stumbles off throttle. the symptoms sound like a bad/sticky IAC motor but on our motors, the motorized throttle body takes place of the IAC. so......try cleaning your throttle body.

turboquattro068
03-27-2007, 07:41 PM
if your throttle body alignment failed, then you need a new tb.......I have a throttle body i can sell you, i just experienced the same problems, but all i need was an alignment, but bought a throttle body also.....Id be willing to give it to you for a good price, let me know.........my paypal account is


www.vaccaman11@hotmail.com

superman_006
03-27-2007, 08:15 PM
18010 - Power Supply Terminal 30: Voltage too Low
P1602 - 35-10 - - - Intermittent
This is a soft code, I have it too becasue of my turbo timmer

sighpost
03-28-2007, 05:07 PM
if your throttle body alignment failed, then you need a new tb.......I have a throttle body i can sell you, i just experienced the same problems, but all i need was an alignment, but bought a throttle body also.....Id be willing to give it to you for a good price, let me know.........my paypal account is


www.vaccaman11@hotmail.com

Sent you an email. I am interested.