PDA

View Full Version : Question: After replacing clutch



beneintray
02-26-2007, 11:12 PM
Hello, i drove B5 A4 for last 2 years.
I was almost time to replace clutch, so i purchased clutch kit from ECS tuning, and take it to local shop.
I could pick it up today.
But i felt something is different than before.
My clutch pedal used have kinda big push-back power(i heard hydrauric something), but now, it has gone.

Actually, when i purchased the car, the clutch was almost gone, and engage point was kinda high compare to my friend's car. So, i really don't know about feeling when the clutch is new.
Is it normal?

bOOOOstedAudi
02-26-2007, 11:31 PM
you cant go byu the engagement point. all are different. my stock clutch was high and so is my stage 3 clutch

CaSp3r9
02-27-2007, 01:23 AM
Same with my South bend OFE HD (stgIII) clutch, it's got a high engagement point. It kinda concerned me at first, but it's normal.

beneintray
02-27-2007, 06:30 AM
thank you for your answer.

I am also wondering there is no more hydrolic push back power on clutch pedal.
is there any possibility that local shop did something wrong?

UN-PIMP-Z-A4
02-27-2007, 06:46 AM
what are you asking?
Are you saying when you step on the clutch pedal there is no pressure and it sinks str8 to the floor?

LateraLex
02-27-2007, 07:30 AM
My engagement point moved over the first two weeks. If you are talking about pedal feel (as in pressure) then I'm thinking this has to do with bleeding your master cylinder and checking the fluid levels.

$teady$upreme
02-27-2007, 09:08 AM
I just changed my clutch as well. My clutch pedal feel is very very soft right now, wouldn't it have a harder feeling (pressure to push back on my foot) after the clutch breaks in?

UN-PIMP-Z-A4
02-27-2007, 10:06 AM
Not really my stage 4 felt "lighter" after the initial break-in period (which was stiffer but nothing overbearing...) and now it feels almost stockish.
That may be because I'm getting use to the pressure.

mike-2ptzero
02-27-2007, 10:47 AM
If the pedal has a mush feel to it then there is air in the system and the shop needs to bleed the slave cylinder.

ActiveMonkey
02-27-2007, 11:06 AM
Not really my stage 4 felt "lighter" after the initial break-in period (which was stiffer but nothing overbearing...) and now it feels almost stockish.
That may be because I'm getting use to the pressure.

When i first got my car i let my father drive it once and he did fine. After getting the Stage 4 clutch and breaking it for for 3 months i let him drive it again... stalled it 3 times.


It feels stockish tp me, but i think i just got used to it. Athough it's about 10x harder than my GF's Eclipse.




Vitaliko, also on Audizine, just got a stage 4 in his car and the pedal had almost no effort. It's about 5x softer than stock with almost ZERO push back. I think somethings wrong, but what could it be?

$teady$upreme
02-27-2007, 03:07 PM
Definitely let us know, i have the same feeling right now. I only drove for like 10 miles max though~


When i first got my car i let my father drive it once and he did fine. After getting the Stage 4 clutch and breaking it for for 3 months i let him drive it again... stalled it 3 times.


It feels stockish tp me, but i think i just got used to it. Athough it's about 10x harder than my GF's Eclipse.




Vitaliko, also on Audizine, just got a stage 4 in his car and the pedal had almost no effort. It's about 5x softer than stock with almost ZERO push back. I think somethings wrong, but what could it be?

mad_circle21
02-27-2007, 03:44 PM
after I got my sb stg II clutch installed it felt like there was no resistance at all and after a while it was back to normal. I also thought there was something wrong, but the guy who intstalled it said he bled it like crazy. I would drive it for a week or two and see what happens. I'm sure it will be fine.

ActiveMonkey
02-27-2007, 03:52 PM
wierd. because we had out clutches installed at the same shop, but mine felt perfect when i went to pick it up. We'll give it a month or so.

ibew5audi
02-27-2007, 05:29 PM
I got the ecs kevlar w/l.w. f.w. It was so easy to push (too easy) when I got the car back. Also took almost 1kmi for the kevlar to break in(it was slipping). It definitely holds now. The engagement point is a joke-about 3" from all the way out. It's the third clutch(counting original) in the car (190kmi+) but they all grabbed in the same spot (i hate it). Anyway- I called and they said it was normal.

Nor_Cal_Driver
02-27-2007, 05:47 PM
My SB STG III is soft also but the return or push back is similar to stock.

onemoremile
02-27-2007, 06:16 PM
If the pedal has a mush feel to it then there is air in the system and the shop needs to bleed the slave cylinder.

Good advice.