PDA

View Full Version : HELP: Coil Spring Compressor Won't fit in Spring?



ActiveMonkey
02-13-2007, 05:20 PM
I'm installing the rear springs on my Eibach Pro-Kit and the Spring Compressors i have won't fit between the coils of the rear springs. What should i do.

I used these
http://www.partsamerica.com/ProductDetail.aspx?categorycode=3492&mfrcode=PBI&mfrpartnumber=648627
on the front springs yesterday and they worked fine, but now they won't fit.


Any help would be appreciated.

europshhrc279
02-13-2007, 05:42 PM
are you sure you need a spring compressor for the back springs? on my car i didnt need it...they came off without a single jump after the nut was loosened ...and then to put it back on it was just a simple pushdown of the spring and have someone put on the top nut ..but maybe its different if you car is quattro

SeanF
02-13-2007, 05:46 PM
i have the same springs... i needed spring compressors, and i used ones like in your pictures yesterday..

i had to dissassemble them to get them in... take the long bolt out and they should angle in there ok...

but then when the spring is on the strut, you wont be able to get them out, angleing them still wont allow enough room, so i put the bolt in and used it to pry them out from the coils... in hindsight, it probably wasnt a good idea, but i was stuck...

ActiveMonkey
02-13-2007, 08:56 PM
i had to dissassemble them to get them in... take the long bolt out and they should angle in there ok...

but then when the spring is on the strut, you wont be able to get them out, angleing them still wont allow enough room, so i put the bolt in and used it to pry them out from the coils... in hindsight, it probably wasnt a good idea, but i was stuck...

Worked like a damn charm. Thanks. It feels and looks so much better!

ProOnThaSnow
02-13-2007, 10:56 PM
"If at first it doesn't fit... force it. She may be mad for a few seconds, but she'll be happy and it'll work soon enough [;)]"

TQMB5
02-14-2007, 11:31 AM
post some pics!

ActiveMonkey
02-14-2007, 11:51 AM
http://i111.photobucket.com/albums/n131/ActiveMonkey/OldVSnew.jpg

http://i111.photobucket.com/albums/n131/ActiveMonkey/DSC03187.jpg

http://i111.photobucket.com/albums/n131/ActiveMonkey/DSC03188.jpg

http://i111.photobucket.com/albums/n131/ActiveMonkey/DSC03189.jpg

http://i111.photobucket.com/albums/n131/ActiveMonkey/DSC03191.jpg

http://i111.photobucket.com/albums/n131/ActiveMonkey/DSC03190.jpg

recognize408
02-14-2007, 01:50 PM
how long after the install were these pics taken ? it might drop more after they settle. looks good.

ActiveMonkey
02-14-2007, 02:36 PM
6 hours, although the car had only been driven about 30 feet.

JMaxx93
02-14-2007, 08:30 PM
Holy balls that looks low.... for just coils. I got the H&R race springs but haven't put them on yet. is my shit gonna be like slammed?

seank
02-14-2007, 09:11 PM
you think that is low[confused]