PDA

View Full Version : Cruise Control Broken?



bellofello
01-12-2007, 10:42 AM
Alright as I'm driving along and hit the cruise it usually works. Just this past week it has been shutting off as I have the cruise control on. I speed up again and reset it but it doesn't hold the speed. Then it won't work for a while. Then I'll try it again and it will work for a couple of minutes then go out again.

Any ideas? Wiring?

SeanF
01-12-2007, 10:46 AM
pretty common problem...

could be the switch, you can try replacing it or opening it up and cleaning it.

Give the search a shot, but i think alot of the troubleshooting for this is on audiworld.

dsswain
01-12-2007, 10:49 AM
Clutch switch under the dash is a quick check. Assuming it is the same as my 2001 S4, there is a plunger type switch that is activated depending on if the clutch is in or out. These can go bad or come out of adjustment. I researched a bit because I had a code "cluth pedal implasible signal" or something like that. It turned out the swich was adjusted wrong or had moved, so that when the clutch was engaged the computer thought it was depressed and wouldn't activate cruise control (which I wish I had on my 2,300 mile trip home after picking the car up). I adjusted this and it's worked ever since.

Not saying it's your problem, but a definete place to start because you said yours will hold for a second and then not work. Maybe the plunger is stuck, it's adjusted right on the edge, or the switch needs to be replaced. Either way it's cheap and I'd start there.

bellofello
01-12-2007, 10:54 AM
Thanks a lot guys, I'll check that clutch pedal switch thing. Where exactly is it?

I'll try giving that switch seanF mentioned a cleaning. Where is that one?

lol

SeanF
01-12-2007, 11:06 AM
its the switch you use to activate the cruise control...

the clutch pedal switch is behind the clutch...

can you start your car without pushing the clutch?

i can, and my cruise still worked for a while... so you may not even have to worry about the clutch switch...

bellofello
01-12-2007, 11:08 AM
no I can't start it without pushing it down ALL the way, so I think it is alright.

To take the switch apart do you just pry it or is there screws. Just asking because my dad stole my car (because his car's seats don't fold down) for a couple of hours to pick up some wood and stuff.

dsswain
01-12-2007, 11:09 AM
http://search.audiworld.com/search.html

Crap, cant post actual thread. But search "Clutch pedal switch pic" in the B5 S4 forums, it's the 4th result.


(have to remove the kickpanel under the steering column)

bellofello
01-12-2007, 11:26 AM
Thanks, I don't think it's that though. I'll check it for sticking though.

jbrentd
01-12-2007, 12:54 PM
vacuum lines can be bad also

wood_e
01-12-2007, 02:23 PM
Hummm... my CC has never worked since I got the car. I am wondering if it's my clutch switch as I can start my car without pushing the clutch. I also heard though if your ABS is acting up CC won't work, and my ABS doesn't work (chipped tone ring).

Anywhere else I should look?

bellofello
01-12-2007, 02:36 PM
If you can start your car without pushing the clutch in, then that would stop your cc for working for sure.

wood_e
01-12-2007, 04:37 PM
Humm... where can I order the clutch switch?

Nukkah03
01-12-2007, 05:36 PM
damn I have this problem too, need to get the clutch switch also. Thanks bellofello I totally forgot about my CC problem lol.

bellofello
01-12-2007, 08:04 PM
no problem [:)], sometimes with all of my problems I forget some of them too