Audizine - An Automotive Enthusiast Community

Results 1 to 21 of 21
  1. #1
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    S4 B6 Transmission Issue

    Guest-only advertisement. Register or Log In now!
    Hi fellow victims of Audi,

    Got a problem, don't know how bad is it, but i'm kind of desperate and looking for some opinions. Got Auto S4 B6. During radiator change forgot one screw for Tranny oil, obviously when started, it leaked out maybe 1/2 quart. Took it too a reputable shop, topped it off and thought all was over. Today, pulling out of the driveway PRNDS lit up. Turned off the car, back on it was gone. Put in R again, PRNDS lights up along with Check Engine. Restarted AGAIN, CEL stays, no other lights remained. Driving in 1,2nd gears, rpm slighty jumping 100-200rpm while it was cold. Going to get the code out, but im wondering what might be the issue. Solenoid? TC? both? Any guidance would be appreciated!

    Thanks,

    Paul

  2. #2
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    Forgot to add. I'm from NJ (woodbridge area). Temp in the early morning around 55ish would say.

  3. #3
    Veteran Member Four Rings Nollywood's Avatar
    Join Date
    Nov 03 2011
    AZ Member #
    83391
    My Garage
    B6 Avant 420-R
    Location
    077, Audiville

    How was it topped up? There's a very specific procedure, if it's not adhered to, the transmission will end up under-filled.
    2003 Audi B6 A4 Quattro Sport Avant, 3.0 | 6-Speed Manual Swap | BOSE | Rear PDC | Factory Votex Kit | OEM B6 S4 Black Optic Grille | Rear Tints | Black Leather | Cruise | H&R Spacers 12/15mm Front / Rear | B7 S4 OEM Alloys

    B6 420-TS Avant - RS6 4.2 BiTurbo, (BCY). B6/7 Hybrid "RS4" OEM Widebody Coming Soon.

  4. #4
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    Not sure exactly but he used pressured pump or something like that. And he kept filling it until it started squirting the oil out.

  5. #5
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    forgot to mention, He said that tranny was overfilled in the first place. so he kept adding as much as possible without overfilling it. I always had this grinding vibrations on some gears on very low rpms when accelerating around 1,100-1,300rpms. dont know if thats related to the current problem though.

  6. #6
    Established Member Three Rings VinnysS4's Avatar
    Join Date
    Nov 12 2015
    AZ Member #
    364349
    Location
    Oregon

    Sounds like RPM hunting from the TC

    Sent from my SM-G550T1 using Audizine mobile app
    1997 VW GTI VR6 (sold), 2003 Audi RS6 (sold), 2010 Audi A4 2.0T (RIP Totaled on 11/2/2015 ) 2005.5 Audi S4

    http://www.audizine.com/forum/showth...-s-s4-timeline

  7. #7
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    Biggie?

  8. #8
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    P0736 is the code

  9. #9
    Established Member Two Rings Velox's Avatar
    Join Date
    Mar 30 2016
    AZ Member #
    371041
    Location
    Oranjestd

    from google:

    P0736 Possible causes Low transmission fluid level

    Read more: https://www.autocodes.com/p0736_audi.html

  10. #10
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    Saw that one. Fluid level is fine 99.9% sure. Now the shop is advising to replace mechatronic because separate solenoids are not sold. How much of that is true?

  11. #11
    Senior Member Two Rings Fourpoint282's Avatar
    Join Date
    Oct 11 2015
    AZ Member #
    361428
    Location
    Atlanta, Georgia

    I had similar issue with mine. The PRNDS is the car going in limp mode. Basically the car is smart enough to keep you from hurting it more. In any case my issue was a solenoid and it cost $6k to fix at Audi dealership. Prob would have cost 20% less at an Indy shop


    Sent from my iPhone using Audizine

  12. #12
    Established Member Three Rings VinnysS4's Avatar
    Join Date
    Nov 12 2015
    AZ Member #
    364349
    Location
    Oregon

    Buy a zip kit from sonnax and do it yourself for like $500 with fluid... if it is in fact solinoids in the mechatronic unit (valve body)

    Sent from my SM-G550T1 using Audizine mobile app
    1997 VW GTI VR6 (sold), 2003 Audi RS6 (sold), 2010 Audi A4 2.0T (RIP Totaled on 11/2/2015 ) 2005.5 Audi S4

    http://www.audizine.com/forum/showth...-s-s4-timeline

  13. #13
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    Which one is it? Or i could get a used mecha unit and stick that in. Just no idea how extensive that is...

  14. #14
    Established Member Three Rings VinnysS4's Avatar
    Join Date
    Nov 12 2015
    AZ Member #
    364349
    Location
    Oregon

    1997 VW GTI VR6 (sold), 2003 Audi RS6 (sold), 2010 Audi A4 2.0T (RIP Totaled on 11/2/2015 ) 2005.5 Audi S4

    http://www.audizine.com/forum/showth...-s-s4-timeline

  15. #15
    Senior Member Three Rings lyates1987's Avatar
    Join Date
    Sep 17 2014
    AZ Member #
    283288
    Location
    Austin/TX
    Items for Sale

    Did he fill it with car on or not? Was tranny temp between 32 and 34 celcius when filling?

  16. #16
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    Car was on, temperature was checked while filling the temp to make sure we do everything by the books. I have a feeling that previous owner overfilled tranny to cover up issues, now once the fluid is normal, pressures dropped to what should be normal and all the issues came out. Hoping that solenoids and the kit that Vinny recommends will solve it... Very weird honestly. Sometimes PRNDS blinks when backing up, sometimes not. Sometimes feels completely normal, sometimes completely off.. Out of ideas..

  17. #17
    Senior Member Four Rings blitz2190's Avatar
    Join Date
    Jul 31 2014
    AZ Member #
    269656
    My Garage
    2004 A4 1.8T Quattro, 2.7T swap Stage 3 APR 6 speed
    Location
    NH
    Items for Sale

    Quote Originally Posted by pauliusmac View Post
    Car was on, temperature was checked while filling the temp to make sure we do everything by the books. I have a feeling that previous owner overfilled tranny to cover up issues, now once the fluid is normal, pressures dropped to what should be normal and all the issues came out. Hoping that solenoids and the kit that Vinny recommends will solve it... Very weird honestly. Sometimes PRNDS blinks when backing up, sometimes not. Sometimes feels completely normal, sometimes completely off.. Out of ideas..
    random though but have you checked your ecu box for water? I'm currently fighting ghost in the wiring with a car that had water damage. Replaced the tcu turns out the plug was beyond repair so now replacing that. I mention that because it was causing random mechanical failure codes and lighting up the prnds.
    Never argue with an idiot, they'll bring you down to their level and beat you with experience.
    2.7T Swap Wiring Guide (Psst this is a link)
    New Build In progress built 2.7 STK 2004 B6 A4- Thread and pic to come

  18. #18
    Established Member Three Rings VinnysS4's Avatar
    Join Date
    Nov 12 2015
    AZ Member #
    364349
    Location
    Oregon

    I have an extra tip tranny if you need ;D

    Sent from my SM-G550T1 using Audizine mobile app
    1997 VW GTI VR6 (sold), 2003 Audi RS6 (sold), 2010 Audi A4 2.0T (RIP Totaled on 11/2/2015 ) 2005.5 Audi S4

    http://www.audizine.com/forum/showth...-s-s4-timeline

  19. #19
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    Mileage? :D thats my plan b. If the whole kit wont help, just swap trannys. And how much $$ u want? :D

  20. #20
    Established Member Three Rings VinnysS4's Avatar
    Join Date
    Nov 12 2015
    AZ Member #
    364349
    Location
    Oregon

    Pulled it at 118k and swapped with a manual
    I don't know on price. $200? It's just taking up space in my garage lol

    Sent from my SM-G550T1 using Audizine mobile app
    1997 VW GTI VR6 (sold), 2003 Audi RS6 (sold), 2010 Audi A4 2.0T (RIP Totaled on 11/2/2015 ) 2005.5 Audi S4

    http://www.audizine.com/forum/showth...-s-s4-timeline

  21. #21
    Active Member Two Rings
    Join Date
    Dec 16 2015
    AZ Member #
    365951
    Location
    Central Jersey

    Ok, still no changes. Now discussing whether change solenoids, or just put a used tranny. Same issues. When Cold put in Reverse, PRNDS lights up, 1,2 Gears downshift clunk (like getting bumped). And Fluctuating RPM's ... On the other note, rather paying some shops to do it, maybe anyone in NJ would like to take a look (would pay and get all the parts) . Now just trying to get down to what should i do.

    Thanks Everyone who are adding to this thread!

    P.S. Hope to get this PITA resolved

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2017 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.