Audizine - An Automotive Enthusiast Community

Results 1 to 11 of 11
  1. #1
    Established Member Two Rings edb8s4's Avatar
    Join Date
    Feb 20 2017
    AZ Member #
    393673
    Location
    New York

    Changed control arms

    Guest-only advertisement. Register or Log In now!
    Changed control arms and it's still making the same clicking and knocking noises it was making before I changed them after everyone that looked the car said it was the control arms any suggestions guys thank you


    Ed

  2. #2
    Active Member One Ring
    Join Date
    Apr 27 2017
    AZ Member #
    398485
    Location
    Dubai, United Arab Emirates

    I think it could be the shocks or the front sway bar could be the problem. Try using some silicon around bushings and makes them fit in a little easier.

  3. #3
    Active Member One Ring
    Join Date
    Jun 24 2017
    AZ Member #
    401653
    Location
    Denver

    Im having the same issue!! i replaced all control arms, Sway links, tie rods, cv axels and wheel bearings and still have a weird noise up front!!! Any advice?

    Sent from my SM-G950U using Audizine mobile app

  4. #4
    Active Member One Ring
    Join Date
    Jun 24 2017
    AZ Member #
    401653
    Location
    Denver

    I put new bilstien shocks and eibach springs all the way around also..

    Sent from my SM-G950U using Audizine mobile app

  5. #5
    Established Member Two Rings edb8s4's Avatar
    Join Date
    Feb 20 2017
    AZ Member #
    393673
    Location
    New York

    Quote Originally Posted by creekwater View Post
    Im having the same issue!! i replaced all control arms, Sway links, tie rods, cv axels and wheel bearings and still have a weird noise up front!!! Any advice?

    Sent from my SM-G950U using Audizine mobile app
    Idk what to tell you man same happened to me no one seems to know anything. Audi keeps saying it's the controls arms even after replacing them. Just do what I did and get you a new car lol


    Ed

  6. #6
    Established Member Two Rings vw754's Avatar
    Join Date
    Jan 18 2008
    AZ Member #
    24277
    Location
    stoke on trent

    try shocker top mounts ??
    anti-roll bar bushes ??

  7. #7
    Active Member One Ring
    Join Date
    Jun 24 2017
    AZ Member #
    401653
    Location
    Denver

    I just changed my motor mounts and snub mount and the front end is quiet!!! Its been 3 days so hopefully i found the culprit

  8. #8
    Established Member Two Rings SimbadCA's Avatar
    Join Date
    May 11 2016
    AZ Member #
    373145
    My Garage
    Audi TT (MK1, 8N) Quattro
    Location
    Camarillo CA

    Iím also replacing my LCA bushing. Presently the LCAs have aluminum outer sleeves on the original bushings.
    Do I re-use or replace these sleeves?
    Do the power flex bushings come with the sleeves?
    Thanks

  9. #9
    Established Member Two Rings edb8s4's Avatar
    Join Date
    Feb 20 2017
    AZ Member #
    393673
    Location
    New York

    Quote Originally Posted by SimbadCA View Post
    Iím also replacing my LCA bushing. Presently the LCAs have aluminum outer sleeves on the original bushings.
    Do I re-use or replace these sleeves?
    Do the power flex bushings come with the sleeves?
    Thanks
    They should come together I believe with the sleeve that youíre mentioning, if Iím correct thatís what makes the bushing


    Ed

  10. #10
    Established Member Two Rings SimbadCA's Avatar
    Join Date
    May 11 2016
    AZ Member #
    373145
    My Garage
    Audi TT (MK1, 8N) Quattro
    Location
    Camarillo CA

    Quote Originally Posted by edb8s4 View Post
    They should come together I believe with the sleeve that youíre mentioning, if Iím correct thatís what makes the bushing


    Ed
    Iíve confirmed with Powerflex USA, that the complete OEM bushing should be removed. The Powerflex solution does not require the use of the outer sleeve...their solution does not require it.


    Sent from my iPad using Audizine

  11. #11
    Established Member Two Rings SimbadCA's Avatar
    Join Date
    May 11 2016
    AZ Member #
    373145
    My Garage
    Audi TT (MK1, 8N) Quattro
    Location
    Camarillo CA

    For the front LCA, the nuts and bolts are being replaced. Why would the rear LCA bolt not be self locking, while the nut on the spindle for the strut is self locking? Should I be concerned?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2017 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.