Audizine - An Automotive Enthusiast Community

Results 1 to 34 of 34
  1. #1
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    A6 4.2 Alternator?

    Guest-only advertisement. Register or Log In now!
    Can anyone find a part number for the alternator for this engine?

    I know its water cooled, and im hoping there are some other alternators that are compatable as well.

    for info - its a 4.2L Quattro - A6 C6 4F (Of course, I AM in the right section)
    190A - Water Cooled

  2. #2
    Senior Member Two Rings
    Join Date
    Feb 16 2012
    AZ Member #
    88302
    My Garage
    2006 Audi A6 4.2L Quattro Sline
    Location
    Los Angeles, Ca


  3. #3
    Established Member Two Rings
    Join Date
    Sep 14 2009
    AZ Member #
    47771
    Location
    Brooklyn, NY

    Thumbs up

    Quote Originally Posted by Tarrant View Post
    Can anyone find a part number for the alternator for this engine?

    I know its water cooled, and im hoping there are some other alternators that are compatable as well.

    for info - its a 4.2L Quattro - A6 C6 4F (Of course, I AM in the right section)
    190A - Water Cooled
    There are 2 different c6 4.2's, I think the difference is FSI and the older non-FSI. I Believe they split in 2007. I have the FSI which is engine code BVJ and I had to replace the alternator last year. I could not find anyone who made or carried the alternator besides the dealer. Even then they did not have any in the US and I had to wait over a week for one to be ordered. I hope this helps.

  4. #4
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Looks like thats what route I will be going.

    Was yours covered by any sort of Warranty? Mines an 08 A6 - so the FSI.

  5. #5
    Established Member Two Rings
    Join Date
    Sep 14 2009
    AZ Member #
    47771
    Location
    Brooklyn, NY

    Post

    Quote Originally Posted by Tarrant View Post
    Looks like thats what route I will be going.

    Was yours covered by any sort of Warranty? Mines an 08 A6 - so the FSI.
    Nope, no warranty. If I remember correctly, it was $1600US with labor.

  6. #6
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    fuuuuuuuuuuuuck me. haha

    I read 1140$ MSRP - but Audi here (both dealers) are owned by 1 person so... no room to bargain.

  7. #7
    Active Member One Ring
    Join Date
    Sep 27 2013
    AZ Member #
    123951
    Location
    Alamo City

    That kind of dollars for an alternator that is only 5 or so years old. Ridiculous...nothing but ridiculous.
    '99 Jaguar XJ8 VDP
    '02 Ranger Rover P38
    '05 LR3
    '06 A6 Quattro

  8. #8
    Active Member One Ring
    Join Date
    May 08 2012
    AZ Member #
    93263
    Location
    Michigan

    That's why I sold my v8... a lot of "special" stuff was done to fit the v8 in the C6 chassis and we all know that "audi" + "special" = $$$$$$$

  9. #9
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Anyone know if there is an easy way to test my voltage regulator? or a fuse that is a common problem for leakage current? When I shut the car off it goes from 13.7v down to about 12 in only a few seconds. Any ideas?

  10. #10
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Nobody? :(

    Guess ill take it to Audi and pay for endless Diagnostics..

  11. #11
    Established Member Two Rings
    Join Date
    Apr 07 2010
    AZ Member #
    57312
    Location
    Southington, CT

    Quote Originally Posted by Tarrant View Post
    Anyone know if there is an easy way to test my voltage regulator? or a fuse that is a common problem for leakage current? When I shut the car off it goes from 13.7v down to about 12 in only a few seconds. Any ideas?
    That is exactly what it should do. With the engine running there will be about 13.7 to 14 V across the battery to keep it charged. Then when the car is off the battery will revert to its standard 12V output voltage.

  12. #12
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Are you sure... by the time I get back to my car its often around or below 11V.. This morning was 10.5V when I started it. (thank god for lots of CCA)

  13. #13
    Senior Member Two Rings
    Join Date
    Feb 16 2012
    AZ Member #
    88302
    My Garage
    2006 Audi A6 4.2L Quattro Sline
    Location
    Los Angeles, Ca

    How old is your battery?

  14. #14
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Brand new. Under a year on it.

  15. #15
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Anyone have a good way using VAG to check leakage currents? or to see which modules are active when they shouldnt be?

    EDIT:

    When you open your trunk and look at the NAV DVD slot - is the Nav unit lit up when the car is off?

  16. #16
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Well back from the battery shop - I am in trouble. 8A draw when locked and sitting for 5.. time to start pulling fuses..

  17. #17
    Senior Member Four Rings SinCityA6's Avatar
    Join Date
    Jul 17 2011
    AZ Member #
    78357
    My Garage
    '07 Mustang GT Tungsten Grey/Black
    Location
    Sin City, USA

    Quote Originally Posted by Tarrant View Post
    Well back from the battery shop - I am in trouble. 8A draw when locked and sitting for 5.. time to start pulling fuses..
    What the hell can be drawing 8amps when sitting and nothing powered on?! The Nav-unit should not be lit up and powered on when the car is off and the key is out of the ignition. That is unless you have a short in the MMI buttons (you can activate the MMI without the key by pressing the buttons (only stays on for 10 minutes). If there is a short, then it could be running all the time but the screen would be active as well. Sorry to hear. Keep us posted on your progress.
    '09 C6.5 A6 3.0t Ibis White/Ebony; Clear Bra, 15% Tint, Smoked Corners, DeBadged Rear w/Black Rings, Tinted Tails, S6 Door Blades, RS6 Grill w/White Rings, Roc*Euro Intake, H&R Springs/Sways, Koni FSDs, Adams Rotors, Akebono Pads, Interior/License Plate LEDs, OEM 4 Spoke Steering Wheel w/Paddles, Escort 9500ix Hardwired
    Mod thread: CLICK

  18. #18
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Went through every single fuse - monitoring current draw (Via VAG-COM) with no results :(

    None of the fuses I pulled did anything, a small change from removing the one for the lower footwell lighting, but thats it.

    Guess its off to Audi to see what they think. Ugh.

  19. #19
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Anyone know how to test the voltage regulator? I have a feeling maybe the diode in it is shot - but I really have no idea.

    1 weird thing - When I had my trickle charger hooked up it would overcharge the battery to almost 16V, whats the deal with that? Any thoughts?

  20. #20
    Senior Member Four Rings SinCityA6's Avatar
    Join Date
    Jul 17 2011
    AZ Member #
    78357
    My Garage
    '07 Mustang GT Tungsten Grey/Black
    Location
    Sin City, USA

    I am starting to wonder of the module connected to the positive terminal of the battery is going bad.
    '09 C6.5 A6 3.0t Ibis White/Ebony; Clear Bra, 15% Tint, Smoked Corners, DeBadged Rear w/Black Rings, Tinted Tails, S6 Door Blades, RS6 Grill w/White Rings, Roc*Euro Intake, H&R Springs/Sways, Koni FSDs, Adams Rotors, Akebono Pads, Interior/License Plate LEDs, OEM 4 Spoke Steering Wheel w/Paddles, Escort 9500ix Hardwired
    Mod thread: CLICK

  21. #21
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Whats the name of the module connected to the positive side? I dont have a bentley manual unfortunately :( (waiting for one for christmas from the gf)

    I can start troubleshooting by bypassing it or measuring the amperage coming from it.

  22. #22
    Established Member Two Rings Treedancer72's Avatar
    Join Date
    Mar 29 2013
    AZ Member #
    112309
    Location
    Stockholm Sweden

    Quote Originally Posted by Tarrant View Post
    Anyone know how to test the voltage regulator? I have a feeling maybe the diode in it is shot - but I really have no idea.

    1 weird thing - When I had my trickle charger hooked up it would overcharge the battery to almost 16V, whats the deal with that? Any thoughts?
    This makes me think you may have gotten a faulty battery, can you test with another battery?

  23. #23
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Its basically a brand new battery, since Last Dec - Took it to the place and it passed testing.. so I dunno. Should I take it out to test it?

  24. #24
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Is it a bad idea to do a reset by unplugging the battery for a bit? What can I damage by doing this?

  25. #25
    Senior Member Four Rings SinCityA6's Avatar
    Join Date
    Jul 17 2011
    AZ Member #
    78357
    My Garage
    '07 Mustang GT Tungsten Grey/Black
    Location
    Sin City, USA

    I cant imagine that it would damage anything. But I am not 100% sure.
    '09 C6.5 A6 3.0t Ibis White/Ebony; Clear Bra, 15% Tint, Smoked Corners, DeBadged Rear w/Black Rings, Tinted Tails, S6 Door Blades, RS6 Grill w/White Rings, Roc*Euro Intake, H&R Springs/Sways, Koni FSDs, Adams Rotors, Akebono Pads, Interior/License Plate LEDs, OEM 4 Spoke Steering Wheel w/Paddles, Escort 9500ix Hardwired
    Mod thread: CLICK

  26. #26
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Car is at Audi today - Ill keep everyone posted on what they say.

  27. #27
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Alright, so heres the updated situation;

    Basically it was a power supply relay that was blown and stuck in the closed loop position.

    Relay code is as follows, Labelled 370 Omron relay - Part No. 8D0 951 253

    Its now only drawing .5A (still 200% of rest normal) so they say if I still have starting problems I should come in for an overnight Draw and Wakeup chart to see whats still coming on.

    So far it seems a lot better, let it sit for a bit and it only went down to 12V - but ill check it in the morning and see how low it gets, then update you then.

    Total cost - 213$ Labor, $48.05 for the relay. Total of 290.88 CAD. Pretty decent for an Audi part haha. I am very happy with that price (vs say... an alternator)

    EDIT: If only I knew it was this.. would have bought it myself... For everyone else though :) http://www.europaparts.com/relay-4h0951253a.html

  28. #28
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Well - Seems like im still having some draw from the battery.. Came out to 10.8V this morning (I check it on the reg now haha) so im going to be going back to Audi for an overnighter. Fudge.

  29. #29
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Address 61: Battery Regul. Labels: 4F0-910-181.lbl
    Part No SW: 4F0 910 181 E HW: 4F0 915 181 A
    Component: J0644 BEM H12 0590
    Revision: 00000000 Serial number: 00000000156382
    Shop #: WSC 93009 999 84799
    VCID: 23452E85E23E3306A91-8076

    Subsystem 1 - Part No: 000 915 105 DL
    Component: von VA0 39020550B5
    Coding: 303030393135313035444C56413033393032303535304235
    Shop #: WSC 12345 384 00290

    02272 - Quiescent Current Stage 1
    000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00100000
    Fault Priority: 7
    Fault Frequency: 5
    Reset counter: 255
    Mileage: 135924 km
    Time Indication: 0
    Date: 2013.12.09
    Time: 11:05:09

    02273 - Quiescent Current Stage 2
    000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00100000
    Fault Priority: 7
    Fault Frequency: 1
    Reset counter: 255
    Time Indication: 0
    Date: 2013.12.09
    Time: 11:09:36


    02256 - Quiescent Current
    001 - Upper Limit Exceeded - Intermittent
    Freeze Frame:
    Fault Status: 00100001
    Fault Priority: 7
    Fault Frequency: 1
    Reset counter: 55
    Mileage: 135935 km
    Time Indication: 0
    Date: 2013.12.10
    Time: 03:28:05

    Codes from my scan today, all from the battery regulator - can anyone tell me ant info about these codes so I can take a looksy at it? Im thinking I have a short in the system somewhere and I need to find it. What can cause these codes other than a shorted wire?

    Cheers,

  30. #30
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Newest scan after a full Reset yesterday

    Address 61: Battery Regul. Labels: 4F0-910-181.lbl
    Part No SW: 4F0 910 181 E HW: 4F0 915 181 A
    Component: J0644 BEM H12 0590
    Revision: 00000000 Serial number: 00000000156382
    Shop #: WSC 93009 999 84799
    VCID: 23452E85E23E3306A91-8076

    Subsystem 1 - Part No: 000 915 105 DL
    Component: von VA0 39020550B5
    Coding: 303030393135313035444C56413033393032303535304235
    Shop #: WSC 12345 384 00290

    5 Faults Found:
    02272 - Quiescent Current Stage 1
    000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00100000
    Fault Priority: 7
    Fault Frequency: 3
    Reset counter: 255
    Mileage: 135954 km
    Time Indication: 0
    Date: 2013.12.10
    Time: 20:54:56

    02277 - Quiescent Current Stage 6
    000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00100000
    Fault Priority: 7
    Fault Frequency: 1
    Reset counter: 255
    Mileage: 135962 km
    Time Indication: 0
    Date: 2013.12.11
    Time: 13:28:54

    02273 - Quiescent Current Stage 2
    000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00100000
    Fault Priority: 7
    Fault Frequency: 1
    Reset counter: 255
    Mileage: 135962 km
    Time Indication: 0
    Date: 2013.12.11
    Time: 13:17:08

    02276 - Quiescent Current Stage 5
    000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00100000
    Fault Priority: 7
    Fault Frequency: 1
    Reset counter: 255
    Mileage: 135962 km
    Time Indication: 0
    Date: 2013.12.11
    Time: 13:28:34

    02256 - Quiescent Current
    001 - Upper Limit Exceeded - Intermittent
    Freeze Frame:
    Fault Status: 00100001
    Fault Priority: 7
    Fault Frequency: 1
    Reset counter: 58
    Mileage: 135962 km
    Time Indication: 0
    Date: 2013.12.11
    Time: 14:29:22

    Can anyone find the relay J329 and tell me what its attached to? im going to start unplugging modules to see if I can figure it out. PLEASE SOMEONE WITH A BENTLEY POST ANYTHING FOR ME :S

  31. #31
    Veteran Member Three Rings Kevin1's Avatar
    Join Date
    Oct 19 2008
    AZ Member #
    34358
    Location
    Long Island

    I can't help you on reading your scan reports. However, I had the overnight battery drain issue in my 05 4.2 a few months back and it turned out that the satellite module had gone bad. They replaced the satellite module and everything has been fine since. By the way my satellite radio was playing fine and I had no indication that anything was wrong with it. Good luck.
    2015 A6 TDI Prestige with 19" Sports Package and Season Dedicated Tires - Oolong Gray Metalic, Nougat Brown Interior, Dark Brown Walnut Inlays, Black Headliner, Driver Assistance Package, Cold Weather Package, Night Vision Assistant with Pedestrian Detection.

    RIP - 2005 A6 4.2 - (February 2005 - August 2014) (142,000 miles)

    C6 TSB Library link (Thanks to Dr. Cold for his help in setting this up) http://uberlame.com/a6_tsb/

  32. #32
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Did they mention how bad the drain was? 8A is basically the highest drain ive seen on the web so far :S

  33. #33
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Final Update - Turns out it was my NEW battery that was causing the problem.

    Since it was not a Varta or Audi battery, I could not code it to the car, unfortunately (even though the manual says its fine) leaving the coding in place and changing the battery anyways messed with the voltage regulation and would drain my car when it wasnt supposed to, aka it wasnt recognizing stages of being low charge.

    From the dealer: "Soon as the ignition is off it goes to 0.05A. then after 10 mins or so 0.150milliamps.
    Currently the bill is at 551.58. ( 220.00 battery - and 2 hours labor @ 142/hr"

    Pretty decent price for finding what could have been an endless electrical demon.

    Ill update in a few weeks with more info, ill be going on holidays Jan 1 - 8th and leaving the car - If I come back to a dead car ill know what happened.

    Cheers all, and thanks to anyone who contributed.

  34. #34
    Established Member Two Rings
    Join Date
    Jan 24 2012
    AZ Member #
    87141
    Location
    Calgary, Alberta, Canada

    Revival - This issue is STILL not fixed :(

    Some days its fine, others its close to dead in the morning.

    I do have 1 question, can anyone tell me if the Power to the Sunroof would cause the car to stay "active" after locking the doors? This is the only thing I can think of, I have my Dashcam connected to it and im afraid its waking the car when it starts to record, it does record when movement or vibrations are detected.. I plan to keep it disconnected for a few days and see if I can notice a difference.

    Also - I can hear an electric whine from the front of the engine when its turned off also - only for a couple of seconds, and after it stops, the rad fan moves (not even a rotation, just rocks slightly). Any thoughts?

    Im running out of ideas. Anyone think a coolant temp sensor could cause this if its going bad?



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2014 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.