Audizine - An Automotive Enthusiast Community

Results 1 to 29 of 29
  1. #1
    Registered Member One Ring
    Join Date
    Aug 09 2009
    AZ Member #
    46128
    My Garage
    2000 Audi S4
    Location
    Floral Park, NY

    why isnt my heater working?! no hot air coming out.. only cold!

    Guest-only advertisement. Register or Log In now!
    hey i have a 2000 audi s4

    i just recently tried to turn the heating on because the weather in NY is turning pretty chilly.

    i turn it on, and put the temp to the highest it can go, and only COLD air is coming out.. no warm / hot air at all.. i tried everything...

    any suggestions of why this is happening?

    thanks in advance!

  2. #2
    Senior Member Two Rings falconcrest32's Avatar
    Join Date
    May 19 2009
    AZ Member #
    42704
    My Garage
    2008 A4 S-Line Quattro 6MT
    Location
    North East, MD
    Items for Sale

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by NY EURO S4 View Post
    hey i have a 2000 audi s4

    i just recently tried to turn the heating on because the weather in NY is turning pretty chilly.

    i turn it on, and put the temp to the highest it can go, and only COLD air is coming out.. no warm / hot air at all.. i tried everything...

    any suggestions of why this is happening?

    thanks in advance!
    try changing ur thermostat
    2008 A4 2.0T Quattro S-Line 6-speed

    | Carbonio Intake | VagCom | Blackout Grille | Michelin Pilot Sport A/S 3 | fly300kts Headlights |
    -------------------------------------------------------
    Coming Soon: Pioneer AVIC-8000NEX
    Working Towards: JHM HFC, JHM Downpipe-Y, JHM/FI B6 S4 Cat-back, JHM FMIC, JHM Stage 2 tune
    Dreaming Of: Big Turbo Kit, B7 RS4, Beer and Boobies

  3. #3
    Veteran Member Four Rings AMC's Avatar
    Join Date
    Jun 15 2007
    AZ Member #
    18840
    My Garage
    2001.5 s4, 2001 porsche 911 996
    Location
    CT
    Items for Sale

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    its your heater core...its a bitch to replace
    Stage 3 2.7t swapped B7 A4
    |Suzuka Gray | DTM front | RS4 rear | Rotiform | Airlift | C-tek |

    ^ FOR SALE ^

    Stage 63463 2001.5 Silver S4
    | GTX2867's | ASP | AWE | Forge | Tilton | 034 | JHM | DuH | EPL | FFE |

    C-tek MotorWerks
    Like us on Facebook

  4. #4
    Registered Member One Ring
    Join Date
    Aug 09 2009
    AZ Member #
    46128
    My Garage
    2000 Audi S4
    Location
    Floral Park, NY

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    oh god.. how much can it run me?

  5. #5
    Veteran Member Three Rings orttauq's Avatar
    Join Date
    Mar 11 2007
    AZ Member #
    16319
    My Garage
    B5 S4/B6 A4qm spt pkg
    Location
    poughkeepsie, ny

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by NY EURO S4 View Post
    oh god.. how much can it run me?
    Hold your horses before you get all worked up. It MAY not be your heater core.

    Thermostats are a common failure which would cause the same thing. The other possibility is that you have an air pocket in your heater core. Did you recently do the timing belt/water pump service or a coolant flush?

    What happens is that your heater core is the highest point in the cooling system plumbing. If you get an air pocket in the system, it usually travels and traps itself in the heater core. You have to burp the system. Also a trick it to rais the front of the car and the air pocket will naturally move and you can burp it out if the expansion tank.

  6. #6
    Veteran Member Three Rings kiellish's Avatar
    Join Date
    Sep 05 2009
    AZ Member #
    47339
    Location
    Tampa, FL

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    sounds like an air pocket if the heater never starts working even after the engine is warmed up fully for a while (gauge is in the center). if it's the heater core, it is a huge job to replace. i replaced the evaporator and heater core on my b5 a4 and it took a couple days. the more you tear into the project, the more parts you have to remove. not sure if it was completely necessary, but i had to remove the main crossmember that goes behind the dash. huge amounts of work.

  7. #7
    Veteran Member Three Rings b5s4tt's Avatar
    Join Date
    Mar 14 2007
    AZ Member #
    16395
    My Garage
    s4
    Location
    queens

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    it may be your climate control as well. my car is having similar issues. search elsewhere there is a test menu for the climate control that displays errors as well. i have many errors in mine. im going to replace mine tomorrow and see if it fixes it.

  8. #8
    Veteran Member Four Rings mholme's Avatar
    Join Date
    Jan 29 2007
    AZ Member #
    15226
    My Garage
    08 S4 00 S4
    Location
    MD
    Items for Sale

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    It sounds silly, but make sure when you turn up the Temp button, that it actually moves the degrees up. The buttons like to stick on the climate control. If the button is stuck on a previous cooler setting and you just crank up the fan speed, you'll still get nothing but cold air. Just a thought.
    08 S4- Stock

    00 S4-APR 93 Piggies Custom True Dual exhaust AWE DTS ECS/Bilstein Coilovers 710N's Samco TBB Omori 52mm boost gauge SOLD

  9. #9
    Senior Member Three Rings jakecro's Avatar
    Join Date
    Feb 08 2007
    AZ Member #
    15507
    My Garage
    '00 S4 6MT 309K mi stock K03s
    Location
    Pittsburgh

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    You could try reverse flushing the heater core by reversing the coolant lines, running for a bit and then draining the system. If it was clogged there will be a lot of flaky debris in the coolant.
    -Jake
    jakecro@gmail.com

    www.audidatabase.com <--feel free to contribute material

    new siggy

    710Ns|CC|VDO Vent Boost Gauge|Piggies|LW Crank Pulley|034 Snub|Hawk HPS|K&N|Continental ExtremeContact DW

  10. #10
    Senior Member Three Rings DoGGRoBBer's Avatar
    Join Date
    Dec 24 2006
    AZ Member #
    14407
    My Garage
    2000 S4, 2008 Touareg
    Location
    Upstate NY

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Your heater core may just be clogged, its a common problem with Audis. Look for the two heater lines that run into your firewall. Disconnect them, add some normal citrus style degreaser into them. Let it sit for 10-15 min. Then force water from your outdoor hose thru them. This gets messy but its worth a try. Repeat till the fluid coming out is clear or atleast clearer that before. Just a thought, my mechanic does atleast 1-2 audis a month with this issue.

    An easy DIY.

    Hope this helps.

    -Mike
    2000 S4 SSP Tuned Stage III ,K04's,SSAC Downpies, Scorpion Exhaust, RS4 Clutch, APR Bi-Pipes, APR Snub mount, VAST MBC & TCD running 20-22 Psi., APR SMIC, Bosch 710N DV's
    2008 VW Touareg

  11. #11
    Senior Member Three Rings YBLEGL's Avatar
    Join Date
    Sep 22 2006
    AZ Member #
    11910
    My Garage
    2000 AUDI S4 2003 Audi Allroad
    Location
    BOSTON

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    I would suggest what doggrober said becuase that will at least tell you if the core is clogged, if water runs through it no problem and its clean its not the core, it could be your thermostat and or climate control unit. Start with the core first its easy to remove those hoses on the firewall.
    MAINTENCE AND STAGE 3 INSTALLS DONE, PM ME, MASS/ RI LINE AREA

    2000 S4 SILVER 6SPEED VAST TUNED STAGE 3

    2003 Audi Allroad 48k and sitting

    2003 GTI 20th Edition Imola Yellow, Some go fast mods **SOLD**

  12. #12
    Veteran Member Four Rings obijohn22's Avatar
    Join Date
    Dec 02 2007
    AZ Member #
    23045
    My Garage
    2001.5 S4, 2013 ZL1 Camaro, 2013 Jetta SE
    Location
    michigan
    Items for Sale

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    I vote temperature sensor. there are several sensors used for the climate control system. If any are faulty the system will not work properly. for instance. the system may think it is 95 degrees in your car or that is is 95 degrees outside. First VAG and see what comes up. then let's go from there. And also as Mholme said, the sticky button. I have had this happen to me persanally.
    "NIGHTMARE" Stage 3+ 2001.5 Brilliant Black S4. VAST sauce

    My shit goes like whoosh boom pshhh and like vroom and junk. So fast.

  13. #13
    Veteran Member Three Rings orttauq's Avatar
    Join Date
    Mar 11 2007
    AZ Member #
    16319
    My Garage
    B5 S4/B6 A4qm spt pkg
    Location
    poughkeepsie, ny

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by obijohn22 View Post
    I vote temperature sensor. there are several sensors used for the climate control system. If any are faulty the system will not work properly. for instance. the system may think it is 95 degrees in your car or that is is 95 degrees outside. First VAG and see what comes up. then let's go from there. And also as Mholme said, the sticky button. I have had this happen to me persanally.
    There's an easy way to see if this might be the problem without diagnostic equipment. If the air temperature sensor(s) are failing, the speed of the fan won't change if you turn the temperature up/down. If it's REALLY 50 degrees inside the car and you turn the temp up to high, the fan speed should turn all the way up. If the car already thinks it's 85 degrees inside, the fan won't come on.

  14. #14
    Veteran Member Four Rings obijohn22's Avatar
    Join Date
    Dec 02 2007
    AZ Member #
    23045
    My Garage
    2001.5 S4, 2013 ZL1 Camaro, 2013 Jetta SE
    Location
    michigan
    Items for Sale

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by qwerty1601 View Post
    There's an easy way to see if this might be the problem without diagnostic equipment. If the air temperature sensor(s) are failing, the speed of the fan won't change if you turn the temperature up/down. If it's REALLY 50 degrees inside the car and you turn the temp up to high, the fan speed should turn all the way up. If the car already thinks it's 85 degrees inside, the fan won't come on.
    good plan. it should def. work to check and see what is up!
    "NIGHTMARE" Stage 3+ 2001.5 Brilliant Black S4. VAST sauce

    My shit goes like whoosh boom pshhh and like vroom and junk. So fast.

  15. #15
    Stage 3 Forum Advertiser Four Rings ECS Tuning-Audi's Avatar
    Join Date
    Oct 02 2006
    AZ Member #
    70746
    Location
    Wadsworth,OH

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    If it were a thermostat the heat would eventually come on after a long drive, 20-30min. Does your car's temp display on the dash properly?

    Also, step 1 is check your coolant level.

  16. #16
    Registered Member One Ring
    Join Date
    Aug 09 2009
    AZ Member #
    46128
    My Garage
    2000 Audi S4
    Location
    Floral Park, NY

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    is there already a thread on the forums that is a tutorial for doing your self for the un-clogging and heater lines? sorry but i am a noob lol and i need some help with this..

    as far as my temp gauge, it DEFF works 100%. even when i am driving for a good 20-30 min and try turning the heater on, it doesnt give out hot air... =[

    THANKS so much though for all replies so far..

  17. #17
    Established Member Two Rings CrazyRobCustoms's Avatar
    Join Date
    Feb 02 2009
    AZ Member #
    38225
    My Garage
    00 S4 Noggy, 2008 F150 SuperCrew
    Location
    Nh

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    I would say heater core is part clogged or you have a air pocket. I'm a Audi/Vw tech, audi's and vw passats mainly start floating in now with the lovely no heat complaint.Corrosion and sediment build up in the heater core. Most of the small passages will be restricted but some will flow fine. So you'll go to flush it and think wow it has good flow. I have heard that a lot of techs are having great luck using CLR (calcium lime rust) cleaner. fill the heater core with it and let it sit for awhile.Half hour maybe. Then flush it out with a hose.to bleed it put the right hose on, then look at the left side hose. Theres a hole in the hose about 3/4 of a inch back. Slide the hose back untill the hole is past the end of the heater core tube and run the motor at 2-3 k untill coolant comes out of the hole.Then push the hose back all the way on. May need to do it twice. Good luck
    Audi Expert level Certified
    A8L technicial Specialist

    I fixem demGerman cars Real Good Man

  18. #18
    Senior Member Three Rings DoGGRoBBer's Avatar
    Join Date
    Dec 24 2006
    AZ Member #
    14407
    My Garage
    2000 S4, 2008 Touareg
    Location
    Upstate NY

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    ^^^^ Didn't I already say that? Does anyone read my posts?.. Geez. Face in palm......
    2000 S4 SSP Tuned Stage III ,K04's,SSAC Downpies, Scorpion Exhaust, RS4 Clutch, APR Bi-Pipes, APR Snub mount, VAST MBC & TCD running 20-22 Psi., APR SMIC, Bosch 710N DV's
    2008 VW Touareg

  19. #19
    Veteran Member Three Rings orttauq's Avatar
    Join Date
    Mar 11 2007
    AZ Member #
    16319
    My Garage
    B5 S4/B6 A4qm spt pkg
    Location
    poughkeepsie, ny

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by DoGGRoBBer View Post
    ^^^^ Didn't I already say that? Does anyone read my posts?.. Geez. Face in palm......
    And it was said a couple of times before you said it. What's your point? Is this a competition or are we just trying to help the guy here?

  20. #20
    Veteran Member Four Rings witwer4444's Avatar
    Join Date
    Dec 13 2008
    AZ Member #
    36320
    My Garage
    02 E39 M5
    Location
    Around

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by mholme View Post
    It sounds silly, but make sure when you turn up the Temp button, that it actually moves the degrees up. The buttons like to stick on the climate control. If the button is stuck on a previous cooler setting and you just crank up the fan speed, you'll still get nothing but cold air. Just a thought.
    Not to thread jack, but my buttons have been slowly starting to stick in my 01 climate control unit in the dash.

    I have found that if the car is cold inside, they are very hard to push and most of them either wont work or wont come back out when I push them in.

    What do you suggest I clean the buttons with?

    thanks and go on with the original OPs questions if you cant answer mine

  21. #21
    Established Member Two Rings B5BiTurboS4's Avatar
    Join Date
    Mar 07 2009
    AZ Member #
    39598
    My Garage
    2002 IMOLA YELLOW S4
    Location
    Bremerton, WA
    Items for Sale

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    There was a DIY on this. How to remove the whole button assembly and clean it...
    Search it up... It should be moved to the DIY section but I havnt seen it. Its very detailed...
    2000 STAGE 3 NOGARO BLUE 6 SPEED S4
    2002 STAGE 2 IMOLA YELLOW 6 SPEED S4 FOR SALE!! PICS ON PROFILE!

  22. #22
    Senior Member Three Rings BoostinonYOU's Avatar
    Join Date
    Apr 03 2006
    AZ Member #
    11189
    My Garage
    02 s4, 08 Thundra, 08 gsxr 1000
    Location
    Moorpark, Ca

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Does anyone elses ambient air temp readout go haywire sometimes ? Mine will go to like -58 degrees... wtf is that all about, IT did the same thing in my 99 a4 as well.
    APR Stage 1 13.0009 @ 105 FULL INTERIOR | 100 OCT RACE GAS

    APR Stage 2+ 12.87. @ 109.10 1.89 60FT. FULL INTERIOR FULL EXHAUST | 93/110 mix

    http://www.youtube.com/watch?v=pCPXI5hMOUI

    I have a faster 1/4 time but no slip, didn't bring my helmet and promptly got kicked off the track w/o time slip :(
    APR | JHM | OZ RACING |

  23. #23
    Registered Member One Ring
    Join Date
    Nov 17 2009
    AZ Member #
    50834
    Location
    Indianapolis/Indiana

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by CrazyRobCustoms View Post
    I would say heater core is part clogged or you have a air pocket. I'm a Audi/Vw tech, audi's and vw passats mainly start floating in now with the lovely no heat complaint.Corrosion and sediment build up in the heater core. Most of the small passages will be restricted but some will flow fine. So you'll go to flush it and think wow it has good flow. I have heard that a lot of techs are having great luck using CLR (calcium lime rust) cleaner. fill the heater core with it and let it sit for awhile.Half hour maybe. Then flush it out with a hose.to bleed it put the right hose on, then look at the left side hose. Theres a hole in the hose about 3/4 of a inch back. Slide the hose back untill the hole is past the end of the heater core tube and run the motor at 2-3 k untill coolant comes out of the hole.Then push the hose back all the way on. May need to do it twice. Good luck
    Hi ,
    I just bought a 1999 VW Passat and this may be one of the problems that have popped up. Also do you know, is the mass air flow sensor and ignition module a possible cause for the car shaking and stalling occassionally?

  24. #24
    Veteran Member Three Rings AWD87's Avatar
    Join Date
    Nov 23 2007
    AZ Member #
    22792
    My Garage
    01 S4
    Location
    Midwest

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    http://www.audiworld.com/tech/eng.html
    First article "Heater Core flush"
    Stage 18/6
    k04s, JHM FMIC, Tune, #60 injectors, 044 Bosch FP, 85mm maf, mbc, Vast stage 3 clutch, 710n's, 034 inlets, 034 tbb, ABD intake, H&R coilovers, 18" Falken Koblenz

  25. #25
    Stage 3 Forum Advertiser Four Rings ECS Tuning-Audi's Avatar
    Join Date
    Oct 02 2006
    AZ Member #
    70746
    Location
    Wadsworth,OH

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by BoostinonYOU View Post
    Does anyone elses ambient air temp readout go haywire sometimes ? Mine will go to like -58 degrees... wtf is that all about, IT did the same thing in my 99 a4 as well.
    Yes, you likely need one of these: Outside Temperature Sensor. They are a common problem.


  26. #26
    Stage 3 Forum Advertiser Four Rings Scotty@Advanced's Avatar
    Join Date
    May 16 2008
    AZ Member #
    28845
    Location
    South Texas

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by NY EURO S4 View Post
    hey i have a 2000 audi s4

    i just recently tried to turn the heating on because the weather in NY is turning pretty chilly.

    i turn it on, and put the temp to the highest it can go, and only COLD air is coming out.. no warm / hot air at all.. i tried everything...

    any suggestions of why this is happening?

    thanks in advance!
    There's any number of things that could be wrong.

    Air bubble in heater coil coolant circuit
    Bad thermostat (will show as engine running too cool)
    Dirty heater coil
    bad Climate control head
    Mixer flap actuator not working
    Plugged up heater core (internally)

  27. #27
    Established Member Two Rings
    Join Date
    May 25 2008
    AZ Member #
    29179
    My Garage
    01 S4, 00 A4 1.8TQM
    Location
    Charleston SC

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Sticky button DIY link:

    http://zener.com/audi/HVAC_cleaning/

  28. #28
    Veteran Member Three Rings DanS4's Avatar
    Join Date
    Oct 03 2008
    AZ Member #
    33802
    My Garage
    01.5 Audi S4, 00 golf Tdi
    Location
    Reading, PA

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    Quote Originally Posted by Chris@ECSTuning View Post
    Yes, you likely need one of these: Outside Temperature Sensor. They are a common problem.


    I replaced mine and the temp is still 184 outside. I believe there is two sensors the one described and one near the cabin filter.
    01.5 S4 ; 00 2 door golf TDi 320k
    VAST tuned k04s, piggies, ASP exhaust, FMIC, Tracksports, DTS, ...

    http://www.socals4.com/

  29. #29
    Stage 3 Forum Advertiser Four Rings Scotty@Advanced's Avatar
    Join Date
    May 16 2008
    AZ Member #
    28845
    Location
    South Texas

    Re: why isnt my heater working?! no hot air coming out.. only cold!

    DanS4 your Avatar rules!



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2014 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.